Forum Navigation
You need to log in to create posts and topics.

AXYZ 4008 Conversion to Masso controller

Earlier this year I was able to get my hands on a nice big 60x100 inch CNC table for a decent price. I then purchased the Vectric VCarve Pro Software to help generate the G-code to run jobs.  It quickly became apparent the AXYZ ToolPath software that I had to use to send the jobs to the machine was conflicting with some of the Vectric gcode.  Most of the problem was the depth control, I really never knew how deep the machine was going to cut.  If I bypassed Vectric and sent a plt drawing through ToolPath all the control seemed to be predictable.  But I wanted the flexibility of the VCarve setups.  I tried all the AXYZ post processors in VCarve, but none really gave me the control I needed/wanted through the ToolPath.  The table used the older controller board, not the "new" A2MC board. So the whole thing was useable, but frustrating and somewhat unpredictable.   Last month I realized one of the 2  X-axis stepper motors was not functioning.  I delved into the rats nest of wires that was the controller box and determined the driver board for the motor was not functioning. The 6410 boards that it used were only available used on ebay, pricing ranging from $80 - $400.  I have been looking over other controller options for months, and the Masso controller seems to be everything I was hoping for.  I cleaned out a lot of wiring from the controller, and have installed some newer driver boards I went with the Leadshine (StepperOnline) DM860T boards,  I am utilizing the old power supply to drive these.   The "rats nest" photo shows one of the Leadshine boards I was trying to get to work on the old signal board.  The voltage, amps, and the step resolution were all within parameters, but apparently the 6410 boards ran up to about 500kHz, whereas any newer board only ran at about 200kHz. I am assuming this was why things were not getting better.  I ordered a Masso G3, and I am trying to prepare the box for it's installation.  the drives now power up, and the motor are engaged just waiting for signals.     I am currently looking over the TB Woods VFD and spindle setup. I think I have an idea of how it should be wired, but if anyone here has any experience with them I would love some input...  I linked the manual below for some light reading.   This is the first project of this sort that I have ever undertaken and if you believe I am overlooking something/anything, I'd really like to hear your thoughts.    If this all works out, I aim to upgrade a 24x48 Vision engraver that has been used as a desk in our shop for the past 3 years..

Thank you in advance  🙂

Uploaded files:
  • 20191030_145208.jpg
  • 20191105_164425.jpg

Looking good @wrexler

You will be able to use the Masso Vectric post processors with your VCarve Pro. I have included a link below


With regards the spindle I suggest you have look at the video on the page below. It will take you through the steps of installing a VFD on Masso and should make the process easier once you have the VFD configured correctly.


Hope this helps




My Masso unit arrived yesterday, and I have the motors and homing sensors all responding.  The motors are calibrated, and the A axis is slaved to the X.  I can execute the home command and everything goes where it should.  I loaded a file, which seems to load and display fine, but when I press the Cycle Start, nothing seems to happen.  The job timer starts, but that's all.. Esc key has no effect. The only button press that seems to so anything is an E-Stop.  Seems like to only way out is to cycle the power..   I feel like I must be missing something simple.. any ideas?





@wrexler - you have to hit the rewind button first. Only on the first time a new file is loaded.

Hi @wrexler

Check out your Spin up time for your spindle as that is sometimes what makes it look like Masso is doing nothing. After an M3 the timer has to timeout before the Program continues further.

Hope this helps



I did hear you reference the Rewind button in one of your videos (thank you for those btw)  I tried that... no help.  For the file shown in the photo below, the spindle doesn't even start up. The job timer just counts, I let it go up to about 6 minutes, the spindle spin up is set for 2000 ms.   I circled the A-axis display, because I wasn't sure what the little "partial character" was there for.  the A is slaved to the X, not sure if this is a normal display for that.  I mention this only because in searching for answers I found another post here that had the A axis "freezing" the progress of a job.  At least that's how I understood it. I didn't see a resolution to that issue.

I created a small circle pocket test job with the conversational feature.  Loaded, rewind, Start... The spindle does actually start on this one, and at about 20 seconds in the Z reports that it has moved .0001 inches. but that's all it does.

Thank you for your help, I do appreciate the input.


Uploaded files:
  • masso2.jpg
  • masso3.jpg

here is the post that I referenced.

To troubleshoot a bit I disengaged the A axis drive belt, then "unslaved" (emancipated?) it.. no help.   The A display  went to 0.000 inches.. but the file still would not run..

Simplified my method, no file loaded.. I used the MDI to start the spindle... no problem.

Tried G28 to home the machine... nothing. g0 x5 command, also nothing

Had to reboot after each... I am attaching my current settings file, hoping someone can help.

Uploaded files:

Problem solved...

The 5th axis that I was not using had no calibration data. This apparently was not acceptable.  Entered some numbers, problem solved.