Forum Navigation
You need to log in to create posts and topics.

Build Log - 3DTek Heavy Mill/Gecko G540/2.2KWSpindle

On Peter's suggestion, I'll be logging the progress of my Heavy Mill build on this thread.  It could be a resource for other builders with the same or similar builds to resolve the inevitable issues that arise along the way.

I started construction May of 2017 getting the mechanicals sorted out reasonably fast.  Other than a couple of holes pre-drilled in the wrong spots and a few parts missing(quickly supplied by Ben at 3DTek) it was simple to follow Ben's videos and written instructions.  The odd email helped too.

I ran all the cables according to the instructions no problem and installed an extra 5mm tube up to the spindle mount for metal milling coolant.

I mounted all the electronics hardware in a clear lidded box under the front of the bench.  In the lower section I've mounted the Invertek 2,2KW 3phase VFD, 48VDC Din rail power supply, and 12VDC Din rail power supply.  I used individual circuit breakers on the supply side of these devices.  In the upper section, the Masso and G540 with fan cooler.

I made some mounting hardware to mount an off the shelf monitor bracket to the corner of bench so the Heavy Mill is self contained.

Then life got in the way and nothing further until January 2019.

Uploaded files:
  • IMG_1331.jpg
  • IMG_1332.jpg
  • IMG_1333.jpg

Starting this week, Monday 7th January, I dusted off the Mill to get things underway.

My goal to start with was to get the gantry moving under Masso control.  I wired up power to the Masso, G540 and cooler and cabinet fan.  Next I mounted the E-Stop button to the bench and wired it into the Masso.  I had the stepper cables already terminated to the Gecko GC-02 DB-09 Breakout board, making connection to the G540 easy.

Time to test the G540.  I disabled the Charge Pump and jumpered terminal 10 and 12, then powered up the 48VDC supply.  I got the green light on the G540 and the Gecko cooling fan spun up.  All the steppers held firm when I pushed on them.  Success.  Powered down for the next step.

Masso to Gecko next.  I crimped on the IDC DB25 connectors to ribbon cable and checked with the multimeter. All ok.  I plugged in the 3DTek Masso/Gecko adaptor to the Masso.  Be careful with this, you need to put your fingers under the Masso to support it while pushing firmly on the board to make it seat properly into the 18 axis sockets.  You'll feel it push home after the initial resistance.  The DB25s were easily installed at both ends.

Masso test time.  I connected the keyboard and monitor and switched on the 12VDC supply.  The screen lit up with the Masso login.  Looked promising.  I had the red fail light on the G540. My mistake was to switch the Charge Pump back on.  Peter told me the Masso doesn't use this so leave it disabled.  Green light back on, time to test jogging.  The E-Stop was flashing so I pressed and released and it stopped flashing.  Home was flashing, but I tested each direction for jogging first.  X worked in both directions.  Z worked in both directions.  Y not so good.  The Y stepper worked, but the A stepper(mirrored Y) on the far side of the gantry would not budge.  I swapped plugs on the G540 to make sure the stepper worked, which it did. It looks like the mirrored Y signals are not reaching the A driver via the Masso/Gecko adaptor.

As of 1855Hrs 10th Jan. I'm at an impasse. I've logged on 3DTek forum for advice and I ask here if anyone has a suggestion.

Cheers, Mike


Do you have the duplication links in the correct locations on the parallel board?

If you have access to DB25 female & male solder connectors, make a test cable with Y & A axis swapped, to determine if the problem is MASSO A axis output or Gecko A axis input.



Uploaded files:
  • MassoGeckoAdaptor.jpg

Nice start Mike, you will be up and running in no time.




I have links across the pins marked on that picture which is the Y Step and Direction. What I don’t understand is how this provides the Y signal to the A axis on the Gecko. Does Masso A axis output go to the Gecko A input?



Those links duplicate the Y Step & Direction for the A axis Step & Direction in the Gecko parallel port. Top row of pins are the 'A axis' S & D pins in the parallel port, so depending on which links/pins used you can duplicate any of the bottom row axis.

The green A & B axis ports (numbered 4 & 5) are the outputs for MASSO 4 & 5 axis versions.

Quote from Breezy on January 10, 2019, 9:11 am

make a test cable with Y & A axis swapped,

With the above test cable you can determine whether the duplication is working or not and if the Gecko A input is OK.

Also I'm assuming that you have reversed the connections of one field on the A axis stepper, so that both steppers turn in the correct direction.



Thanks Arie,

I think I get it. When I checked where each pin appears with my multimeter, the top row appears on the appropriate pins on the Masso connector. The bottom pins of each Step and Direction group are commoned. I assume they should appear on the DB25 A axis but they don’t. I’ll test it out today. Yes I reversed the A stepper wiring.

Updated to the current software. Interesting that F1 screen doesn’t default to the password window. I had to click on it with mouse that I didn’t have before to enter password.



I made up the cable today and proved the G540 A axis works (whew). I’m thinking the Masso/Gecko adaptor is faulty. Tomorrow I’ll parallel the Y to the A pins in the DB25. If that works, I’ll leave it and move on. I was thinking of tossing the Adaptor and directly wiring the Masso to the G540, but I’ve misplaced the Masso plugs. Punishment for taking too long from the build.?


Quote from aussiemike on January 11, 2019, 10:55 am


I’m thinking the Masso/Gecko adaptor is faulty. Tomorrow I’ll parallel the Y to the A pins in the DB25. I was thinking of tossing the Adaptor and directly wiring the Masso to the G540, but I’ve misplaced the Masso plugs. Punishment for taking too long from the build.?



Before making any changes to your DB25 connector and cable, buzz the adaptor out (from the pins on the MASSO side to the DB25 connector) and confirm that it's faulty, if so contact Ben @ 3DTek and get him to replace it.

Ben has been very helpful with the problems that I have struck in getting the Men's Shed HM working.




I buzzed out the adaptor board. Definitely no circuit from the link pins to the DB25.  I soldered in wires to complete the circuit and I now have correct jogging.  Ben asked via the 3DTek Forum for the Version number and to contact support, but I was confident I could get it going and it's way past warranty period.  Also impatient to make some progress before life gets in the way again.

Now I'm working out how to calibrate travel and make homing work right.