Forum Navigation
Please or Register to create posts and topics.

Inventor 2021 CAM Masso Plasma Post Error

Hello,

It's my first post.

I tried to Post Process a quite simple part with Masso Plasma PostProcessor, both in Autodesk Inventor 2021 CAM & Fusion, however I got the same nc Failed Errors (Warning & Fatal Error):

 

Warning:

"Work offset has not been specified. Using G53 as WCS."

 

Error:

"Radius compensation is not supported.
Error at line: 560
Error in operation: '2D Profile2'
Failed while processing onLinear() for record 316.
Error: Failed to execute configuration.
Stop time: Thursday, March 25, 2021 8:44:55 PM
Post processing failed."

 

Am I doing something wrong? The used Masso Plasma Post Processor has been downloaded from Autodesk's Official page.

 

Thank you in advance.

@gsuper7

Check your parameters when creating your toolpath that you have compensation set to computer NOT controller.

Regards,

Arie.

 

 

Hello Arie,

Thank you for your reply. I will do so and I will let you know. However, the Inventor CAM simulation seemed and worked OK...

Gsuper7

 

Warning:

"Work offset has not been specified. Using G53 as WCS."

Error:

"Radius compensation is not supported.
Error at line: 560
Error in operation: '2D Profile2'
Failed while processing onLinear() for record 316.
Error: Failed to execute configuration.
Stop time: Thursday, March 25, 2021 8:44:55 PM
Post processing failed."

 

Really not an expert in fact I am struggling with the first program and getting the offsets to run also..

What I do know is according to the Masso Documentation that G 53 is not a valid code call in Masso and neither is the G0- G 43 series of offsets.  Sounds like the outputting programs are calling these codes from there routine and just not supported with Masso.  Must be a work around for it.

Regards,

Steve

 

Quote from Airnut on March 27, 2021, 5:22 am

What I do know is according to the Masso Documentation that G 53 is not a valid code call in Masso and neither is the G0- G 43 series of offsets.  Sounds like the outputting programs are calling these codes from there routine and just not supported with Masso.  Must be a work around for it.

Steve,

From MASSO documentation https://docs.masso.com.au/supported-g-codes/g53-move-in-absolute-machine-coordinates

Autodesk's HSM post processor is the same PP for all of Autodesk's versions of CAM software, as they have the same HSM CAM "engine" in them. So if it works in Fusion for MASSO it will work in Inventor.

Quote from gsuper7 on March 27, 2021, 1:32 am

Hello Arie,

Thank you for your reply. I will do so and I will let you know. However, the Inventor CAM simulation seemed and worked OK...

Georgios,

Yes the simulation will look correct, it is the setting in the Passes tab that causes the post processor to throw the error, there is nothing wrong with the post processor it is correctly trapping a incorrect user setting for MASSO PP.

Regards,

Arie.

Uploaded files:
  • Screenshot-2021-03-27-082921.jpg

Hello,

Thanks to Arie, the coming Error has been solved. Thanks to everybody and especially Arie! It's great to seem how fast MASSO support helped me overcame this issue! Great support for a great Product!!!

In case that someone else faces the same Error in the future, please find below an Autodesk Link, explaining "What is Cutter Compensation":

https://www.autodesk.com/products/fusion-360/blog/cutter-compensation/

Moreover, I have to mention that in Inventor 2021 CAM, I had only the options "In computer" & "In control" (by default, the "In control" was selected and I suppose that this caused the PP Error). Since probably Masso does not support "In control" Compensation Type, please select "In computer" and choose the methods you like. Then, the PP runs fine.

Regards,

George

@gsuper7

George,

Another tip, right click in any parameter and select "Set as default" for any changes that you have to make constantly.

Regards,

Arie.

Hello Arie,

Yes I know that. Detailed directions can be found below:

https://knowledge.autodesk.com/support/fusion-360/troubleshooting/caas/sfdcarticles/sfdcarticles/Definition-of-default-settings-for-specific-CAM-operations-in-Fusion-360-and-Inventor-CAM.html