Forum Navigation
Please or Register to create posts and topics.

MASSO G3 won’t move

hello I have just got a g3 for my router and I can’t get it to move. The DRO is moving on the computer screen however nothin is moving.

I had previously tested the machine using a mach 3 breakout board with a manual controller attached so I know the drives work. I have got leadshine ES-D808 servo drives and I have connected in the differential type controller as per the attachment.

 

Help. Please

Uploaded files:
  • BDEF62C1-B5EF-4DAF-9515-E2326835A9A2.jpeg
Hamish has reacted to this post.
Hamish

OK so I have worked out on the g2 version the x,y,z are differential outputs and the A,B are PNP, (I think)

where the G3 they are all differential outputs. The controller I am using has the same connections as the CS-D-1008 and I have connected it correctly.

Help

Uploaded files:
  • 3DB8A296-E13B-4B93-9B83-CCDC3288FB69.png

So I have investigated the enable input and this basically will shut down the stepper motor and remove the holding current when I apply 5 volts to the terminals. As per the drive instructions it says to leave it unconnected.

The system just sits with all of the motors with a holding current locked in position.

Uploaded files:
  • 113DE1F0-C591-4131-8486-FEFE8BB3FEB3.jpeg
  • 8B1FCF2E-C701-495D-9085-2A5ED41A48D6.png

Hi Hamish,

From your description you appear to have the axis wired correctly.

If you are working on just one axis at this time have you tried connecting to a different one and seeing if that works?

Can you please share a screen print of the settings on one of the axis you are having trouble with and one of the F2 screeen?  To get a screen print just press  CTRL+P on your keyboard and it will dump a screen print to your flash drive.

Could you share a photo of the connections into the drive and one of the Masso axis connection?

Cheers

Peter

Print screen as requested

Uploaded files:
  • Print-Screen-002.bmp
  • Print-Screen-003.bmp
  • stepper-connections.jpg
  • controller-connections.jpg

Thanks Hamish,

Looking at the Z axis setting you have the soft limits set incorrectly.

Set you Maximum travel to 0 and your minimum travel to -117

The Z axis is usually zeroed at the top making the maximum 0 and the minimum must be less than the maximum so this would be -117.

Let me know is this helps.

Cheers

Peter

No this didn't work

I have an MPG as well and its not working either

Uploaded files:
  • Print-Screen-004.bmp
  • Print-Screen-005.bmp

I see in the screen print that you have the MPG set to off.

The MPG axis should change to indicate X,Y,Z etc as you rotate axis selector.

Also you can only jog with the MPG when you are in the F3 jog screen.

Have you tried the using buttons on the jog screen?

Cheers

Peter

MPG is currently disconnected and I have tried it from both the MPG and the jog screen. Neither will work.

 

I have included a picture of the board layout for clarity.  The estop is temporarily hanging for the moment while the door is off the enclosure.

I tried temporarily wiring the homeing limits is as well and this had no effect with them connected or not

 

Uploaded files:
  • layout.jpg

When I am in the F3 screen and I operate the buttons with the mouse or use the MGP the numbers in the highlighted areas move as if the machine should be moving however the crosshair in the left hand corner never moves

Uploaded files:
  • screen-notes.JPG