Forum Navigation
Forum breadcrumbs - You are here:ForumForums: Questions & AnswersOutputs stuck
Please or Register to create posts and topics.

Outputs stuck

All,

I’m trying to hook up a relay to my Masso  outputs for a vacuum system (it’s a cnc wood router) and all of my outputs appear to be stuck in their current state. I can assign them in the setup screen, and I can invert them, but their state never changes.  This applies to the TTL outputs as well as the relay outputs; I have tried using the P1-16 macro assignments as well as commands such as the flood coolant output (which is what I actually want to use).
The outputs currently in a high state are actually high and will actuate the relays, and the low states will not, so its at least correct with the state on the screen.

any ideas?

 

Wes

@whonnel

Wes,

Have you issued the relevant M commands in the MDI to operate the assigned outputs.

In regards to the relays connected to outputs, what version of MASSO do you have?

There is a difference between G2 & G3 as to what type of relay you can connect. Read the bottom of this page MASSO G2 Drive and Relay wiring if you have a G2 else this page  TTL Outputs for a G3.

Regards,

Arie.

 

 

Arie,

I have the G2 version of Masso, and have tried the M62/63 commands in MDI. No luck. I am also within the bounds of the current ratings of the outputs as I’m using optoisolated relays

 

Wes

Wes,

M62/63 have been removed from G2 and replaced by M64/65 in software update v3.47.4

From the update email.

  • IMPORTANT Change: M62 and M63 commands have now been moved to M64 and M65, please see this link for more information: M62 and M63.

Regards,

Arie.

I have tried M62/63 on the old firmware, as well as M64/65 on the new firmware all to no avail.

the spindle outputs change fine (CW/CCW) but I can’t change the state of any other output pin. I would thing that regardless of the program outputs I should be able to cycle the state using the invert feature in the setup screen, but they don’t seem to work in that manner either. Is there anything I can look for hardware wise that could be an issue?

wes

Good day.

I have the same problem.

What was the solution to the problem?